Setting Listen Port

Kitzi
Posts: 4
Joined: Thu Apr 23, 2015 5:41 pm

Setting Listen Port

Postby Kitzi » Thu Apr 23, 2015 5:46 pm

How can i set the Port in the /etc/evok.conf to :8080. In my file there is no entry for that.
Thank's in advanced
tomas_hora
Site Admin
Posts: 298
Joined: Wed Oct 29, 2014 9:56 am

Re: Setting Listen Port

Postby tomas_hora » Sat Apr 25, 2015 3:28 pm

Hello,

it is defined in /opt/evok/evok.py file line 48: define("port", default=80, help="run on the given port", type=int)

I will change add an option in the conf file during the next week
Kitzi
Posts: 4
Joined: Thu Apr 23, 2015 5:41 pm

Re: Setting Listen Port

Postby Kitzi » Sun Apr 26, 2015 7:47 pm

WORKed! Fine :-) and Thank's
bbbowden
Posts: 15
Joined: Mon Feb 15, 2016 9:15 pm

Re: Setting Listen Port

Postby bbbowden » Fri Sep 02, 2016 5:38 pm

I tried using the config file to change the port Evok was listening on and it wouldn't work. I found in the evok.py file at line 461:

Code: Select all

port = config.getintdef(Config, "MAIN", "port", 80)
define ("port", default=port, help="Listening port settings", type=bool)


which appears where the config sets the port but it wouldn't work. However, when I changed it to:

Code: Select all

port = config.getintdef(Config, "MAIN", "port", 80)
define ("port", default=8181, help="Listening port settings", type=bool)


it worked fine. Any ideas?
BlackSoll
Posts: 31
Joined: Sat Jul 04, 2015 9:07 am

Re: Setting Listen Port

Postby BlackSoll » Fri Sep 02, 2016 7:04 pm

Try

Code: Select all

sudo nano /etc/evok.conf

Return to “Official Evok API”

Who is online

Users browsing this forum: No registered users and 2 guests