problum whit the 8-Relay Addon EMO-R8

martijnperdaan
Posts: 4
Joined: Tue Jul 05, 2016 12:30 pm

problum whit the 8-Relay Addon EMO-R8

Postby martijnperdaan » Tue Jul 05, 2016 12:31 pm

i connected 2 times a 8-Relay Addon EMO-R8 board to my unipi but i can't find/controll them when i use the comand (sudo i2cdetect -y 1)
i don't see them and the data led on de 8-Relay Addon EMO-R8 board is red can anyone help me ?

gr Martijn Perdaan
ps. Sorry for my bad English
tomas_hora
Site Admin
Posts: 298
Joined: Wed Oct 29, 2014 9:56 am

Re: problum whit the 8-Relay Addon EMO-R8

Postby tomas_hora » Thu Jul 07, 2016 7:37 am

Have you configured the addresses on the second two boards? By default they are all set to 0x21 address and address 0x20 are used for the onboard relays. Make sure that each board has configured different address using the dip switch.
martijnperdaan
Posts: 4
Joined: Tue Jul 05, 2016 12:30 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby martijnperdaan » Thu Jul 07, 2016 12:39 pm

if have address 0x22 en 0x23 of the 2 boards
User avatar
jaroslav_sobota
Posts: 32
Joined: Tue Dec 02, 2014 1:16 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby jaroslav_sobota » Thu Jul 07, 2016 12:46 pm

Previous conversation with Martijn also revealed that he uses 10 cm cable which was provided with the board.

Martijn: did you try connecting only one extension board? Can you please post here the output of i2cdetect with a) plain UniPi board and b) with the 0x22 extension board attached?

And just to make sure: Are you able to control the onboard relays?
REX Control System for Raspberry Pi - Advanced automation and control solutions
http://www.rexcontrols.com/rex-control-system-raspberry-pi
martijnperdaan
Posts: 4
Joined: Tue Jul 05, 2016 12:30 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby martijnperdaan » Thu Jul 07, 2016 1:11 pm

yes i can controle the onboard relays

and 1 connectet one board but it stil don't work
Attachments
board.jpg
putty.png
putty.png (10.25 KiB) Viewed 4239 times
User avatar
jaroslav_sobota
Posts: 32
Joined: Tue Dec 02, 2014 1:16 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby jaroslav_sobota » Thu Jul 07, 2016 3:57 pm

Apart from the micro USB power supply, which is not necessary, I do not see anything suspicious.

I'm out of ideas :-( Any hints, Tomas?
REX Control System for Raspberry Pi - Advanced automation and control solutions
http://www.rexcontrols.com/rex-control-system-raspberry-pi
tomas_hora
Site Admin
Posts: 298
Joined: Wed Oct 29, 2014 9:56 am

Re: problum whit the 8-Relay Addon EMO-R8

Postby tomas_hora » Thu Jul 07, 2016 4:35 pm

I have two ideas.... Are the jumpers on UniPi near the place for battery both set to the side of battery? Do you have another RJ12/11 cable to test it or at least re-crimp the one we provided?
martijnperdaan
Posts: 4
Joined: Tue Jul 05, 2016 12:30 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby martijnperdaan » Thu Jul 07, 2016 5:53 pm

i have found the problum i have put te jumper p1 back in so that the raspberry don't neet his own powersuply and it workt i can se them now
User avatar
jaroslav_sobota
Posts: 32
Joined: Tue Dec 02, 2014 1:16 pm

Re: problum whit the 8-Relay Addon EMO-R8

Postby jaroslav_sobota » Thu Jul 07, 2016 9:11 pm

Well done! Still I'd like to know why it was not working with your previous setup. Any ideas, Tomas?
REX Control System for Raspberry Pi - Advanced automation and control solutions
http://www.rexcontrols.com/rex-control-system-raspberry-pi

Return to “UniPi Extension modules (official)”

Who is online

Users browsing this forum: No registered users and 1 guest